Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS00N3hoLXF4cXYtbWd2Z84AAwIN

kube-httpcache is vulnerable to Cross-Site Request Forgery (CSRF)

Impact

A request forgery attack can be performed on Varnish Cache servers that have the HTTP/2 protocol turned on. An attacker may introduce characters through the HTTP/2 pseudo-headers that are invalid in the context of an HTTP/1 request line, causing the Varnish server to produce invalid HTTP/1 requests to the backend. This may in turn be used to successfully exploit vulnerabilities in a server behind the Varnish server.
-- https://varnish-cache.org/security/VSV00011.html#vsv00011

Patches

This is fixed in Varnish 6.0.11; Varnish 6.0.11 is available in kube-httpcache versions v0.7.1 and later.

Workarounds

See upstream mitigation hints.

References

Permalink: https://github.com/advisories/GHSA-47xh-qxqv-mgvg
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS00N3hoLXF4cXYtbWd2Z84AAwIN
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: over 1 year ago
Updated: over 1 year ago


Identifiers: GHSA-47xh-qxqv-mgvg
References: Repository: https://github.com/mittwald/kube-httpcache
Blast Radius: 1.0

Affected Packages

go:github.com/mittwald/kube-httpcache
Dependent packages: 0
Dependent repositories: 0
Downloads:
Affected Version Ranges: < 0.7.1
Fixed in: 0.7.1
All affected versions: 0.1.0, 0.1.1, 0.1.2, 0.1.3, 0.1.4, 0.1.5, 0.2.0, 0.2.1, 0.2.2, 0.3.0, 0.3.1, 0.3.2, 0.3.3, 0.3.4, 0.4.0, 0.4.1, 0.4.2, 0.5.0, 0.6.0, 0.6.1, 0.7.0
All unaffected versions: 0.7.1, 0.7.2, 0.8.0