Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS00NGNjLTQzcnAtNTk0N84AA4lA

JupyterLab vulnerable to potential authentication and CSRF tokens leak

Impact

Users of JupyterLab who click on a malicious link may get their Authorization and XSRFToken tokens exposed to a third party when running an older jupyter-server version.

Patches

JupyterLab 4.1.0b2, 4.0.11, and 3.6.7 were patched.

Workarounds

No workaround has been identified, however users should ensure to upgrade jupyter-server to version 2.7.2 or newer which includes a redirect vulnerability fix.

References

Vulnerability reported by user @davwwwx via the bug bounty program sponsored by the European Commission and hosted on the Intigriti platform.

Permalink: https://github.com/advisories/GHSA-44cc-43rp-5947
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS00NGNjLTQzcnAtNTk0N84AA4lA
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 1 month ago
Updated: 11 days ago


CVSS Score: 7.6
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L

Identifiers: GHSA-44cc-43rp-5947, CVE-2024-22421
References:

Affected Packages

pypi:notebook
Versions: >= 7.0.0, <= 7.0.6
Fixed in: 7.0.7
pypi:jupyterlab
Versions: <= 3.6.6, >= 4.0.0, <= 4.0.10
Fixed in: 3.6.7, 4.0.11