Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS00Njg1LTJ4NXItNjVwas4AA6qH

Pebble service manager's file pull API allows access by any user

Impact

Note: "Pebble" here refers to Canonical's service manager, not the Let's Encrypt ACME test server.

The API behind pebble pull, used to read files from the workload container by Juju charms, allows access from any user, instead of just admin. In Juju Kubernetes sidecar charms, Pebble and the charm run as root, so they have full access. But if another restricted unix user gains local access to the container host, they could hit the Pebble GET /v1/files?action=read API and would be allowed to read any file in the workload container, for example an ssh key or database password or other sensitive information. If there are ssh keys they could then potentially ssh into the workload, or if something like a database password they could log into the database.

Note that this requires local user access to the host machine. It seems unlikely that an attacker could gain this level of access in a Juju Kubernetes context, but if someone did and there's sensitive information in files accessible to Pebble, the consequences are bad.

To reproduce the issue, go back to the Pebble version in Juju 2.9 (5842ea68c9c7), do pebble run as root in one terminal window, then in another terminal window, as a regular user, use the pebble pull CLI. You will be able to pull any file as a regular user.

Patches

The original patch is commit https://github.com/canonical/pebble/commit/cd326225b9b0be067da7d8858e2c912078cbbbd5. There's also https://github.com/canonical/pebble/pull/406, which fixes this issue in more recent Pebble versions (that PR also fixes a separate issue we introduced more recently, but hasn't been released in Juju yet).

We released the fix in the following Pebble versions:

Juju will be releasing patch versions with this fix shortly:

References

Permalink: https://github.com/advisories/GHSA-4685-2x5r-65pj
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS00Njg1LTJ4NXItNjVwas4AA6qH
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 1 month ago
Updated: about 1 month ago


CVSS Score: 6.5
CVSS vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N

Identifiers: GHSA-4685-2x5r-65pj, CVE-2024-3250
References: Repository: https://github.com/canonical/pebble
Blast Radius: 8.2

Affected Packages

go:github.com/canonical/pebble
Dependent packages: 6
Dependent repositories: 18
Downloads:
Affected Version Ranges: < 1.1.1, >= 1.8.0, < 1.10.1, >= 1.5.0, < 1.7.3, >= 1.2.0, < 1.4.1
Fixed in: 1.1.1, 1.10.2, 1.7.3, 1.4.2
All affected versions: 1.2.0, 1.3.0, 1.4.0, 1.5.0, 1.6.0, 1.7.0, 1.7.1, 1.7.2, 1.8.0, 1.9.0, 1.9.1, 1.10.0
All unaffected versions: 1.1.1, 1.4.1, 1.4.2, 1.7.3, 1.7.4, 1.10.1, 1.10.2, 1.11.0