Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS00Njk2LWc3amoteGcyaM4AAuES

Mapbox is vulnerable to Integer Overflow

An integer overflow exists in Mapbox's closed source gl-native library prior to version 10.6.1, which is bundled with multiple Mapbox products including open source libraries. The overflow is caused by large image height and width values when creating a new Image and allows for out of bounds writes, potentially crashing the Mapbox process.

Permalink: https://github.com/advisories/GHSA-4696-g7jj-xg2h
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS00Njk2LWc3amoteGcyaM4AAuES
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: almost 2 years ago
Updated: over 1 year ago


CVSS Score: 7.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Identifiers: GHSA-4696-g7jj-xg2h, CVE-2022-38216
References: Repository: https://github.com/mapbox/mapbox-maps-android
Blast Radius: 12.2

Affected Packages

maven:com.mapbox.mapboxsdk:mapbox-android-core
Dependent packages: 11
Dependent repositories: 42
Downloads:
Affected Version Ranges: < 10.6.1
Fixed in: 10.6.1
All affected versions: 0.1.0, 0.1.1, 0.2.0, 0.2.1, 1.0.0, 1.1.0, 1.2.0, 1.3.0, 1.4.0, 1.4.1, 1.4.2, 1.4.3, 2.0.0, 2.0.1, 3.0.0, 3.1.0, 3.1.1, 3.2.0, 4.0.0
All unaffected versions: