Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS00ZjZ4LWc1dmgtOGptNc4AAnpw

Stored XSS vulnerability in Jenkins Active Choices Plugin

Jenkins Active Choices Plugin 2.5.2 and earlier does not escape reference parameter values.

This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Job/Configure permission.

Jenkins Active Choices Plugin 2.5.3 escapes reference parameter values.

Permalink: https://github.com/advisories/GHSA-4f6x-g5vh-8jm5
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS00ZjZ4LWc1dmgtOGptNc4AAnpw
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: 7 months ago


CVSS Score: 4.6
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N

Identifiers: GHSA-4f6x-g5vh-8jm5, CVE-2021-21616
References: Repository: https://github.com/jenkinsci/active-choices-plugin
Blast Radius: 1.0

Affected Packages

maven:org.biouno:uno-choice
Affected Version Ranges: <= 2.5.2
Fixed in: 2.5.3