Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS00ajRnLWZwOTMtcXZyd84AAi-h

Jenkins buildgraph-view Plugin vulnerable to stored Cross-site Scripting

Jenkins buildgraph-view Plugin 1.8 and earlier does not escape the description of builds shown in its view, resulting in a stored cross-site scripting vulnerability exploitable by users able to change build descriptions.

Permalink: https://github.com/advisories/GHSA-4j4g-fp93-qvrw
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS00ajRnLWZwOTMtcXZyd84AAi-h
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: over 1 year ago
Updated: about 1 year ago


CVSS Score: 5.4
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-4j4g-fp93-qvrw, CVE-2019-16562
References:

Affected Packages

maven:org.jenkins-ci.plugins:buildgraph-view
Versions: <= 1.8
No known fixed version