Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS00cDR3LTZoNTQtZzg4Nc3sNg

Improper Input Validation in Apache Santuario XML Security

Apache Santuario XML Security for Java before 1.5.6, when applying Transforms, allows remote attackers to cause a denial of service (memory consumption) via crafted Document Type Definitions (DTDs), related to signatures.

Permalink: https://github.com/advisories/GHSA-4p4w-6h54-g885
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS00cDR3LTZoNTQtZzg4Nc3sNg
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: almost 2 years ago
Updated: about 2 months ago


Identifiers: GHSA-4p4w-6h54-g885, CVE-2013-4517
References: Repository: https://github.com/apache/santuario-java
Blast Radius: 0.0

Affected Packages

maven:org.apache.santuario:xmlsec
Dependent packages: 352
Dependent repositories: 2,584
Downloads:
Affected Version Ranges: < 1.5.6
Fixed in: 1.5.6
All affected versions: 1.4.3, 1.4.4, 1.4.5, 1.4.6, 1.4.7, 1.4.8, 1.5.0, 1.5.1, 1.5.2, 1.5.3, 1.5.4, 1.5.5
All unaffected versions: 1.5.6, 1.5.7, 1.5.8, 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.0.8, 2.0.9, 2.0.10, 2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.1.5, 2.1.6, 2.1.7, 2.1.8, 2.2.0, 2.2.1, 2.2.2, 2.2.3, 2.2.4, 2.2.5, 2.2.6, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 4.0.0, 4.0.1, 4.0.2