Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS00cTJwLWh3bXItcWN4Y84AA9nF

OPCFoundation.NetStandard.Opc.Ua.Core buffer-management vulnerability

A buffer-management vulnerability in OPC Foundation OPCFoundation.NetStandard.Opc.Ua.Core before 1.5.374.54 could allow remote attackers to exhaust memory resources. It is triggered when the system receives an excessive number of messages from a remote source. This could potentially lead to a denial of service (DoS) condition, disrupting the normal operation of the system.

Permalink: https://github.com/advisories/GHSA-4q2p-hwmr-qcxc
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS00cTJwLWh3bXItcWN4Y84AA9nF
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: 9 days ago
Updated: 6 days ago


CVSS Score: 7.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Identifiers: GHSA-4q2p-hwmr-qcxc, CVE-2024-33862
References: Repository: https://github.com/OPCFoundation/UA-.NETStandard
Blast Radius: 1.0

Affected Packages

nuget:OPCFoundation.NetStandard.Opc.Ua.Core
Dependent packages: 30
Dependent repositories: 0
Downloads: 2,815,283 total
Affected Version Ranges: < 1.5.374.54
Fixed in: 1.5.374.54
All affected versions: 0.0.3, 0.0.6, 0.0.7, 0.0.8, 0.0.9, 0.1.0, 0.1.1, 0.1.2, 0.1.3, 0.1.5, 0.1.6, 0.1.7, 0.1.8, 0.1.9, 0.2.0, 0.2.1, 0.2.2, 0.2.3, 0.2.4, 1.5.37-1.3-beta, 1.5.37-2.1-rc, 1.5.37-2.110-rc2, 1.5.37-2.113, 1.5.37-3.3-preview, 1.5.37-3.121, 1.5.37-4.27, 1.5.37-4.36
All unaffected versions: