An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS00cjlnLXc0OHEtOGp3bc4AAviu

HyperDown vulnerable to Cross-site Scripting

HyperDown is a markdown parser written for the Chinese website SegmentFault. Improper validation of the href attribute allows for Cross-site Scripting. At publication there are no patched versions, and no known workarounds.

Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: over 1 year ago
Updated: over 1 year ago

CVSS Score: 6.1
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-4r9g-w48q-8jwm, CVE-2022-25849
References: Blast Radius: 4.7

Affected Packages

Dependent packages: 4
Dependent repositories: 6
Downloads: 8,331 total
Affected Version Ranges: <= 2.4.27
No known fixed version
All affected versions: 2.4.9, 2.4.10, 2.4.13, 2.4.14, 2.4.15, 2.4.16, 2.4.17, 2.4.18, 2.4.19, 2.4.20, 2.4.21, 2.4.23, 2.4.24, 2.4.25, 2.4.26, 2.4.27