Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS00d3h3LTQyd3gtMndmeM4AA5MP

Apache Solr Schema Designer blindly "trusts" all configsets

Incorrect Permission Assignment for Critical Resource, Improper Control of Dynamically-Managed Code Resources vulnerability in Apache Solr.

This issue affects Apache Solr from 8.10.0 through 8.11.2, from 9.0.0 before 9.3.0.

The Schema Designer was introduced to allow users to more easily configure and test new Schemas and configSets.
However, when the feature was created, the "trust" (authentication) of these configSets was not considered.
External library loading is only available to configSets that are "trusted" (created by authenticated users), thus non-authenticated users are unable to perform Remote Code Execution.
Since the Schema Designer loaded configSets without taking their "trust" into account, configSets that were created by unauthenticated users were allowed to load external libraries when used in the Schema Designer.

Users are recommended to upgrade to version 9.3.0 or 8.11.3, both of which fix the issue.

Permalink: https://github.com/advisories/GHSA-4wxw-42wx-2wfx
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS00d3h3LTQyd3gtMndmeM4AA5MP
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Low
Classification: General
Published: 21 days ago
Updated: 21 days ago


Identifiers: GHSA-4wxw-42wx-2wfx, CVE-2023-50292
References:

Affected Packages

maven:org.apache.solr:solr-core
Versions: >= 8.10.0, < 8.11.3, >= 9.0.0, < 9.3.0
Fixed in: 8.11.3, 9.3.0