Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS00djJxLWhqeDMtYzR2cs4AAq98

Magento remote code execution vulnerability

A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with privileges to modify product catalogs can trigger PHP file inclusion through a crafted XML file that specifies product design update.

As per the Magento Release 2.3.3, if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.

Permalink: https://github.com/advisories/GHSA-4v2q-hjx3-c4vr
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS00djJxLWhqeDMtYzR2cs4AAq98
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: almost 2 years ago
Updated: 17 days ago


CVSS Score: 8.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-4v2q-hjx3-c4vr, CVE-2019-8154
References:

Affected Packages

packagist:magento/community-edition
Versions: >= 2.3.0, < 2.3.2-p2, >= 2.2.0, < 2.2.10
Fixed in: 2.3.2-p2, 2.2.10