Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS00eHI0LTg5bTUtNDZjN84AAy4z

eslint-detailed-reporter vulnerable to cross-site scripting

A vulnerability was found in mportuga eslint-detailed-reporter up to 0.9.0 and classified as problematic. Affected by this issue is the function renderIssue in the library lib/template-generator.js. The manipulation of the argument message leads to cross site scripting. The attack may be launched remotely. The name of the patch is 505c190efd4905990db6207863bdcbd9b1d7e1bd. It is recommended to apply a patch to fix this issue. VDB-226310 is the identifier assigned to this vulnerability.

Permalink: https://github.com/advisories/GHSA-4xr4-89m5-46c7
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS00eHI0LTg5bTUtNDZjN84AAy4z
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Low
Classification: General
Published: about 1 year ago
Updated: 8 months ago


CVSS Score: 3.5
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N

Identifiers: GHSA-4xr4-89m5-46c7, CVE-2022-4942
References: Repository: https://github.com/mportuga/eslint-detailed-reporter
Blast Radius: 7.0

Affected Packages

npm:eslint-detailed-reporter
Dependent packages: 43
Dependent repositories: 98
Downloads: 56,151 last month
Affected Version Ranges: <= 0.9.0
No known fixed version
All affected versions: 0.5.1, 0.5.2, 0.5.3, 0.5.4, 0.5.5, 0.5.6, 0.5.7, 0.5.8, 0.5.9, 0.6.0, 0.6.1, 0.6.2, 0.6.3, 0.6.4, 0.6.5, 0.6.6, 0.6.7, 0.6.8, 0.6.9, 0.6.10, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.7.4, 0.8.0, 0.9.0