Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS01MnJoLTVycGotYzN3Ns3jTw

Improper handling of multiline messages in node-irc

node-irc is a socket wrapper for the IRC protocol that extends Node.js' EventEmitter. The vulnerability allows an attacker to manipulate a Matrix user into executing IRC commands by having them reply to a maliciously crafted message. Incorrect handling of a CR character allowed for making part of the message be sent to the IRC server verbatim rather than as a message to the channel.
The vulnerability has been patched in node-irc version 1.2.1.

Permalink: https://github.com/advisories/GHSA-52rh-5rpj-c3w6
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS01MnJoLTVycGotYzN3Ns3jTw
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 2 years ago
Updated: over 1 year ago


Identifiers: GHSA-52rh-5rpj-c3w6
References: Repository: https://github.com/matrix-org/node-irc
Blast Radius: 0.0

Affected Packages

npm:matrix-org-irc
Dependent packages: 3
Dependent repositories: 196
Downloads: 558 last month
Affected Version Ranges: <= 1.2.0
Fixed in: 1.2.1
All affected versions: 1.0.0, 1.0.1, 1.1.0, 1.1.1, 1.2.0
All unaffected versions: 1.2.1, 1.3.0, 1.4.0, 1.5.0, 2.0.0, 2.0.1, 2.1.0, 2.2.0, 3.0.0