Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS01MnY0LXd4cngtZ2pqbc4AAu-S

Jenkins Apprenda Plugin has Missing Authorization vulnerability

Jenkins Apprenda Plugin 2.2.0 and earlier does not perform a permission check in an HTTP endpoint.

This allows attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins. Those can be used as part of an attack to capture the credentials using another vulnerability.

As of publication of this advisory, there is no fix.

Permalink: https://github.com/advisories/GHSA-52v4-wxrx-gjjm
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS01MnY0LXd4cngtZ2pqbc4AAu-S
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: almost 2 years ago
Updated: 9 months ago


CVSS Score: 4.3
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Identifiers: GHSA-52v4-wxrx-gjjm, CVE-2022-41251
References: Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:apprenda
Affected Version Ranges: <= 2.2.0
No known fixed version