An open API service providing security vulnerability metadata for many open source software ecosystems.
Denial of Service Vulnerability in ActiveRecord’s PostgreSQL adapter
There is a potential denial of service vulnerability present in ActiveRecord’s PostgreSQL adapter.
This has been assigned the CVE identifier CVE-2022-44566.
Versions Affected: All. Not affected: None. Fixed Versions: 184.108.40.206 (Rails LTS), 220.127.116.11, 18.104.22.168
Impact: In ActiveRecord <22.214.171.124 and <126.96.36.199, when a value outside the range for a 64bit signed integer is provided to the PostgreSQL connection adapter, it will treat the target column type as numeric. Comparing integer values against numeric values can result in a slow sequential scan resulting in potential Denial of Service. Releases
The fixed releases are available at the normal locations. Workarounds
Ensure that user supplied input which is provided to ActiveRecord clauses do not contain integers wider than a signed 64bit representation or floats. Patches
To aid users who aren’t able to upgrade immediately we have provided patches for the supported release series in accordance with our maintenance policy 1 regarding security issues. They are in git-am format and consist of a single changeset.
6-1-Added-integer-width-check-to-PostgreSQL-Quoting.patch - Patch for 6.1 series 7-0-Added-integer-width-check-to-PostgreSQL-Quoting.patch - Patch for 7.0 series
Source: GitHub Advisory Database
Published: 20 days ago
Updated: 8 days ago
Identifiers: GHSA-579w-22j4-4749, CVE-2022-44566
Fixed in: 188.8.131.52, 184.108.40.206, 220.127.116.11, 18.104.22.168