Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS01OTQ2LW1wdzUtcHF4eM0t4A

Incorrect Default Permissions in Cobbler

An issue was discovered in Cobbler before 3.3.1. Files in /etc/cobbler are world readable. Two of those files contain some sensitive information that can be exposed to a local user who has non-privileged access to the server. The users.digest file contains the sha2-512 digest of users in a Cobbler local installation. In the case of an easy-to-guess password, it's trivial to obtain the plaintext string. The settings.yaml file contains secrets such as the hashed default password.

Permalink: https://github.com/advisories/GHSA-5946-mpw5-pqxx
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS01OTQ2LW1wdzUtcHF4eM0t4A
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 2 years ago
Updated: about 1 year ago


CVSS Score: 7.1
CVSS vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Identifiers: GHSA-5946-mpw5-pqxx, CVE-2021-45083
References: Repository: https://github.com/cobbler/cobbler
Blast Radius: 7.4

Affected Packages

pypi:cobbler
Dependent packages: 0
Dependent repositories: 11
Downloads: 216 last month
Affected Version Ranges: < 3.3.1
Fixed in: 3.3.1
All affected versions: 3.1.2, 3.2.1, 3.2.2, 3.3.0
All unaffected versions: 3.3.1, 3.3.2, 3.3.3, 3.3.4