Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS01Y3FtLWNyeG0tNnFwds0bSA

Buffer overrun in CGI.escape_html

A buffer overrun vulnerability was discovered in CGI.escape_html. This can lead to a buffer overflow when a user passes a very large string (> 700 MB) to CGI.escape_html on a platform where long type takes 4 bytes, typically, Windows.

Permalink: https://github.com/advisories/GHSA-5cqm-crxm-6qpv
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS01Y3FtLWNyeG0tNnFwds0bSA
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: over 2 years ago
Updated: 6 months ago


CVSS Score: 9.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-5cqm-crxm-6qpv, CVE-2021-41816
References: Repository: https://github.com/ruby/cgi
Blast Radius: 26.4

Affected Packages

rubygems:cgi
Dependent packages: 26
Dependent repositories: 497
Downloads: 12,269,104 total
Affected Version Ranges: < 0.1.0.1, >= 0.2.0, < 0.2.1, >= 0.3.0, < 0.3.1
Fixed in: 0.1.0.1, 0.2.1, 0.3.1
All affected versions: 0.1.0, 0.1.1, 0.2.0, 0.2.1, 0.2.2, 0.3.0, 0.3.1, 0.3.2, 0.3.3, 0.3.4, 0.3.5, 0.3.6, 0.4.0, 0.4.1
All unaffected versions: