Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS01YzVmLTd2ZnEtMzczMs4AArZl

JMESPath for Ruby uses unsafe JSON.load when safe JSON.parse is preferable

jmespath.rb (aka JMESPath for Ruby) before 1.6.1 uses JSON.load in a situation where JSON.parse is preferable.

Permalink: https://github.com/advisories/GHSA-5c5f-7vfq-3732
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS01YzVmLTd2ZnEtMzczMs4AArZl
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: almost 2 years ago
Updated: about 1 year ago


CVSS Score: 9.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-5c5f-7vfq-3732, CVE-2022-32511
References: Repository: https://github.com/jmespath/jmespath.rb
Blast Radius: 44.7

Affected Packages

rubygems:jmespath
Dependent packages: 14
Dependent repositories: 36,181
Downloads: 1,047,776,134 total
Affected Version Ranges: < 1.6.1
Fixed in: 1.6.1
All affected versions: 0.2.0, 0.9.0, 1.0.0, 1.0.1, 1.0.2, 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.3.0, 1.3.1, 1.4.0, 1.5.0, 1.6.0
All unaffected versions: 1.6.1, 1.6.2