Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS01YzhwLXFoY2gtcWh4Ns4AAuf2

Deluge Web-UI vulnerable to XSS through a crafted torrent file

The Deluge Web-UI is vulnerable to cross-site scripting through a crafted torrent file. The the data from torrent files is not properly sanitised as it's interpreted directly as HTML. Someone who supplies the user with a malicious torrent file can execute arbitrary Javascript code in the context of the user's browser session.

Permalink: https://github.com/advisories/GHSA-5c8p-qhch-qhx6
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS01YzhwLXFoY2gtcWh4Ns4AAuf2
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: almost 2 years ago
Updated: over 1 year ago


CVSS Score: 6.1
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-5c8p-qhch-qhx6, CVE-2021-3427
References: Blast Radius: 12.9

Affected Packages

pypi:deluge
Dependent packages: 0
Dependent repositories: 130
Downloads: 2,160 last month
Affected Version Ranges: >= 0, < 2.1.0
Fixed in: 2.1.0
All affected versions: 2.0.0, 2.0.2, 2.0.3, 2.0.4, 2.0.5
All unaffected versions: 2.1.0, 2.1.1