Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS01YzljLTZ4ODctZjl2bc4AAyfJ

zstd vulnerable to buffer overrun

A vulnerability was found in zstd v1.4.10, where an attacker can supply an empty string as an argument to the command line tool to cause buffer overrun.

Permalink: https://github.com/advisories/GHSA-5c9c-6x87-f9vm
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS01YzljLTZ4ODctZjl2bc4AAyfJ
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 1 year ago
Updated: 10 months ago


CVSS Score: 7.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Identifiers: GHSA-5c9c-6x87-f9vm, CVE-2022-4899
References: Repository: https://github.com/facebook/zstd
Blast Radius: 24.9

Affected Packages

pypi:zstd
Dependent packages: 48
Dependent repositories: 1,060
Downloads: 957,642 last month
Affected Version Ranges: < 1.5.4.0
Fixed in: 1.5.4.0
All affected versions:
All unaffected versions: 1.1.4, 1.2.0, 1.3.1, 1.3.3, 1.3.4
swift:github.com/facebook/zstd
Dependent packages: 0
Dependent repositories: 2
Downloads:
Affected Version Ranges: < 1.5.4
Fixed in: 1.5.4
All affected versions: 0.0.29, 0.1.0, 0.1.1, 0.4.3, 0.4.4, 0.4.5, 0.4.6, 0.4.7, 0.5.0, 0.5.1, 0.6.0, 0.6.1, 0.6.2, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.7.4, 0.7.5, 0.8.0, 0.8.1, 1.0.0, 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.2.0, 1.3.0, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.5, 1.3.6, 1.3.7, 1.3.8, 1.4.0, 1.4.1, 1.4.2, 1.4.3, 1.4.4, 1.4.5, 1.4.7, 1.4.8, 1.4.9, 1.4.10, 1.5.0, 1.5.1, 1.5.2
All unaffected versions: 1.5.4, 1.5.5, 1.5.6