Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS01Z3d4LXdmOWctcjVteM4AAv2W

NodeBB vulnerable to Cross-Site Request Forgery

A vulnerability was found in NodeBB up to 2.5.7. This affects an unknown part of the file /register/abort. The manipulation leads to cross-site request forgery. It is possible to initiate the attack remotely. Upgrading to version 2.5.8 is able to address this issue. The name of the patch is 2f9d8c350e54543f608d3d4c8e1a49bbb6cdea38. It is recommended to upgrade the affected component.

Permalink: https://github.com/advisories/GHSA-5gwx-wf9g-r5mx
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS01Z3d4LXdmOWctcjVteM4AAv2W
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: over 1 year ago
Updated: over 1 year ago


CVSS Score: 4.3
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Identifiers: GHSA-5gwx-wf9g-r5mx, CVE-2022-3978
References: Repository: https://github.com/NodeBB/NodeBB
Blast Radius: 2.1

Affected Packages

npm:nodebb
Dependent packages: 1
Dependent repositories: 3
Downloads: 71 last month
Affected Version Ranges: < 2.5.8
Fixed in: 2.5.8
All affected versions: 0.4.3, 0.6.1, 0.7.0, 0.8.2, 1.4.0
All unaffected versions: