Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS01cHFmLXJ2bTctM3dnd84AAwgU

collective.contact.widget is vulnerable to cross-site scripting

collective.contact.widget is an add-on is part of the collective.contact.* suite. A vulnerability classified as problematic was found in collective.contact.widget up to 1.12. This vulnerability affects the function title of the file src/collective/contact/widget/widgets.py. The manipulation leads to cross site scripting. The attack can be initiated remotely. The name of the patch is 5da36305ca7ed433782be8901c47387406fcda12. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-216496.

Permalink: https://github.com/advisories/GHSA-5pqf-rvm7-3wgw
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS01cHFmLXJ2bTctM3dnd84AAwgU
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: over 1 year ago
Updated: 12 months ago


CVSS Score: 6.1
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-5pqf-rvm7-3wgw, CVE-2022-4638
References: Repository: https://github.com/collective/collective.contact.widget
Blast Radius: 3.7

Affected Packages

pypi:collective.contact.widget
Dependent packages: 1
Dependent repositories: 4
Downloads: 268 last month
Affected Version Ranges: < 1.13
Fixed in: 1.13
All affected versions: 1.2.1, 1.2.2
All unaffected versions: