Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS01d2ZwLTg2NDMtYzU4eM4AAZnQ

Improper Input Validation in Apache POI

Apache POI before 3.10.1 and 3.11.x before 3.11-beta2 allows remote attackers to cause a denial of service (CPU consumption and crash) via a crafted OOXML file, aka an XML Entity Expansion (XEE) attack.

Permalink: https://github.com/advisories/GHSA-5wfp-8643-c58x
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS01d2ZwLTg2NDMtYzU4eM4AAZnQ
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: about 1 month ago


Identifiers: GHSA-5wfp-8643-c58x, CVE-2014-3574
References: Blast Radius: 0.0

Affected Packages

maven:org.apache.poi:poi
Dependent packages: 2,109
Dependent repositories: 75,041
Downloads:
Affected Version Ranges: = 3.11-beta1, < 3.10.1
Fixed in: 3.11-beta2, 3.10.1
All affected versions: 3.10.1, 4.0.0, 4.0.1, 4.1.0, 4.1.1, 4.1.2, 5.0.0, 5.1.0, 5.2.0, 5.2.1, 5.2.2, 5.2.3, 5.2.4, 5.2.5
All unaffected versions: