Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS01dmNjLTg2d20tNTQ3cc4AA6DQ

Improper Privilege Management in djangorestframework-simplejwt

djangorestframework-simplejwt version 5.3.1 and before is vulnerable to information disclosure. A user can access web application resources even after their account has been disabled due to missing user validation checks via the for_user method.

Permalink: https://github.com/advisories/GHSA-5vcc-86wm-547q
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS01dmNjLTg2d20tNTQ3cc4AA6DQ
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 1 month ago
Updated: about 1 month ago


Identifiers: GHSA-5vcc-86wm-547q, CVE-2024-22513
References: Repository: https://github.com/dmdhrumilmistry/CVEs
Blast Radius: 0.0

Affected Packages

pypi:djangorestframework-simplejwt
Dependent packages: 59
Dependent repositories: 16,191
Downloads: 2,109,005 last month
Affected Version Ranges: <= 5.3.1
No known fixed version
All affected versions: 1.2.1, 1.5.1, 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 3.2.1, 3.2.2, 3.2.3, 4.0.0, 4.1.0, 4.1.1, 4.1.2, 4.1.3, 4.1.4, 4.1.5, 4.2.0, 4.3.0, 4.4.0, 4.5.0, 4.6.0, 4.7.0, 4.7.1, 4.7.2, 4.8.0, 5.0.0, 5.1.0, 5.2.0, 5.2.1, 5.2.2, 5.3.0, 5.3.1