Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS01eDRnLXE1cmMtMzZqcM4AA5Cl

Etcd pkg Insecure ciphers are allowed by default

Vulnerability type

Cryptography

Detail

The TLS ciphers list supported by etcd by default contains weak ciphers.

Workarounds

Provide a desired ciphers using the --cipher-suites flag as described with examples in the security documentation

References

Find out more on this vulnerability in the security audit report

For more information

If you have any questions or comments about this advisory:

Permalink: https://github.com/advisories/GHSA-5x4g-q5rc-36jp
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS01eDRnLXE1cmMtMzZqcM4AA5Cl
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Low
Classification: General
Published: 27 days ago
Updated: 27 days ago


Identifiers: GHSA-5x4g-q5rc-36jp
References:

Affected Packages

go:go.etcd.io/etcd/client/pkg/v3
Versions: < 3.3.23, >= 3.4.0-rc.0, <= 3.4.9
Fixed in: 3.3.23, 3.4.10