Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS02MnBtLW1ncmgtN3A2Oc4AAivQ

Incorrect Authorization in Jenkins Script Security Plugin

A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.67 and earlier related to the handling of default parameter expressions in closures allowed attackers to execute arbitrary code in sandboxed scripts.

Permalink: https://github.com/advisories/GHSA-62pm-mgrh-7p69
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS02MnBtLW1ncmgtN3A2Oc4AAivQ
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 1 year ago
Updated: 2 months ago


CVSS Score: 8.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-62pm-mgrh-7p69, CVE-2019-16538
References:

Affected Packages

maven:org.jenkins-ci.plugins:script-security
Versions: <= 1.67
Fixed in: 1.68