Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS02NjIzLWM2bXItNjczN84AA6vz

Apache Zeppelin: Denial of service with invalid notebook name

Improper Input Validation vulnerability in Apache Zeppelin when creating a new note from Zeppelin's UI. This issue affects Apache Zeppelin from 0.10.1 before 0.11.0.

Users are recommended to upgrade to version 0.11.0, which fixes the issue.

Permalink: https://github.com/advisories/GHSA-6623-c6mr-6737
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS02NjIzLWM2bXItNjczN84AA6vz
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 1 month ago
Updated: 17 days ago


CVSS Score: 5.3
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Identifiers: GHSA-6623-c6mr-6737, CVE-2024-31862
References: Repository: https://github.com/apache/zeppelin
Blast Radius: 9.2

Affected Packages

maven:org.apache.zeppelin:zeppelin-server
Dependent packages: 0
Dependent repositories: 54
Downloads:
Affected Version Ranges: >= 0.10.1, < 0.11.0
Fixed in: 0.11.0
All affected versions: 0.10.1
All unaffected versions: 0.6.0, 0.6.1, 0.6.2, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.8.0, 0.8.1, 0.8.2, 0.9.0, 0.10.0, 0.11.0, 0.11.1