Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS02Nmo4LWM4M20tZ2o1Zs4AA6wb

Apache Zeppelin remote code execution by adding malicious JDBC connection string

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Zeppelin.

The attacker can inject sensitive configuration or malicious code when connecting MySQL database via JDBC driver. This issue affects Apache Zeppelin: before 0.11.1.

Users are recommended to upgrade to version 0.11.1, which fixes the issue.

Permalink: https://github.com/advisories/GHSA-66j8-c83m-gj5f
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS02Nmo4LWM4M20tZ2o1Zs4AA6wb
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: about 2 months ago
Updated: 24 days ago


CVSS Score: 9.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-66j8-c83m-gj5f, CVE-2024-31864
References: Repository: https://github.com/apache/zeppelin
Blast Radius: 0.0

Affected Packages

maven:org.apache.zeppelin:zeppelin-jdbc
Dependent packages: 1
Dependent repositories: 1
Downloads:
Affected Version Ranges: < 0.11.1
Fixed in: 0.11.1
All affected versions: 0.6.0, 0.6.1, 0.6.2, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.8.0, 0.8.1, 0.8.2, 0.9.0, 0.10.0, 0.10.1, 0.11.0
All unaffected versions: 0.11.1