Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Advisories: GSA_kwCzR0hTQS02ZzhxLXFmcHYtNTd3cM4AAxFy

CakePHP Database\\Query::offset() and limit() methods are vulnerable to SQL injection

Impact

The Cake\Database\Query::limit() and Cake\Database\Query::offset() methods are vulnerable to SQL injection if passed un-sanitized user request data.

Patches

This issue has been fixed in 4.2.12, 4.3.11, 4.4.10

Workarounds

Using CakePHP's Pagination library will mitigate this issue, as will validating or casting parameters to these methods.

References

https://bakery.cakephp.org/2023/01/06/cakephp_4211_4311_4410_released.html

Permalink: https://github.com/advisories/GHSA-6g8q-qfpv-57wp

Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: 16 days ago
Updated: 11 days ago

CVSS Score: 9.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-6g8q-qfpv-57wp, CVE-2023-22727
References:

Affected Packages

packagist:cakephp/database
Versions: >= 4.4.0, < 4.4.10, >= 4.3.0, < 4.3.11, >= 4.2.0, < 4.2.12
Fixed in: 4.4.10, 4.3.11, 4.2.12
packagist:cakephp/cakephp
Versions: >= 4.4.0, < 4.4.10, >= 4.3.0, < 4.3.11, >= 4.2.0, < 4.2.12
Fixed in: 4.4.10, 4.3.11, 4.2.12