Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS02aDY3LTkzNHItODJnN84AA3RQ

Bypass of field access control in strapi-plugin-protected-populate

Impact

Users are able to bypass the field level security. This means fields that they where not allowed to populate could be populated anyway even in the event that they tried to populate something that they don't have access to.

Patches

This issue has been patched in 1.3.4

Workarounds

None

Permalink: https://github.com/advisories/GHSA-6h67-934r-82g7
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS02aDY3LTkzNHItODJnN84AA3RQ
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: 8 months ago
Updated: 8 months ago


CVSS Score: 5.3
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Identifiers: GHSA-6h67-934r-82g7, CVE-2023-48218
References: Repository: https://github.com/strapi-community/strapi-plugin-protected-populate
Blast Radius: 0.0

Affected Packages

npm:strapi-plugin-protected-populate
Dependent packages: 0
Dependent repositories: 1
Downloads: 360 last month
Affected Version Ranges: < 1.3.4
Fixed in: 1.3.4
All affected versions: 1.0.0, 1.1.0, 1.2.0, 1.3.0, 1.3.1, 1.3.2, 1.3.3
All unaffected versions: 1.3.4, 1.3.5, 1.3.6