Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS02bXY4LTk1eDUteGNxOc4AA3OV

H2O local file inclusion vulnerability

A Local File Inclusion (LFI) vulnerability exists in the h2o-3 REST API, allowing unauthenticated remote attackers to read arbitrary files on the server with the permissions of the user running the h2o-3 instance. This issue affects the default installation and does not require user interaction. The vulnerability can be exploited by making specific GET or POST requests to the ImportFiles and ParseSetup endpoints, respectively. This issue was identified in version 3.40.0.4 of h2o-3.

Permalink: https://github.com/advisories/GHSA-6mv8-95x5-xcq9
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS02bXY4LTk1eDUteGNxOc4AA3OV
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: 6 months ago
Updated: about 1 month ago


CVSS Score: 9.3
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:N

Identifiers: GHSA-6mv8-95x5-xcq9, CVE-2023-6038
References: Blast Radius: 14.9

Affected Packages

maven:ai.h2o:h2o-core
Dependent packages: 33
Dependent repositories: 40
Downloads:
Affected Version Ranges: <= 3.40.0.4
No known fixed version
All affected versions: