Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS02cW14LTQyaDItajhoNs4AA7I9

.NET Elevation of Privilege Vulnerability

Microsoft Security Advisory CVE-2024-21409 | .NET Elevation of Privilege Vulnerability

Executive summary

Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 6.0, .NET 7.0 ,and .NET 8.0. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability.

A use-after-free vulnerability exists in WPF which may result in Elevation of Privilege when viewing untrusted documents. This is a Windows only vulnerability.

Announcement

Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/303

Mitigation factors

This vulnerability affects only WPF-based applications.

Affected software

Affected Packages

The vulnerability affects any Microsoft .NET Core project if it uses any of affected packages versions listed below

.NET 6.0

Package name Affected version Patched version
Microsoft.WindowsDesktop.App.Runtime.win-arm64 < = 6.0.28 6.0.29
Microsoft.WindowsDesktop.App.Runtime.win-x64 < = 6.0.28 6.0.29
Microsoft.WindowsDesktop.App.Runtime.win-x86 < = 6.0.28 6.0.29

.NET 7.0

Package name Affected version Patched version
Microsoft.WindowsDesktop.App.Runtime.win-arm64 <= 7.0.17 7.0.18
Microsoft.WindowsDesktop.App.Runtime.win-x64 <= 7.0.17 7.0.18
Microsoft.WindowsDesktop.App.Runtime.win-x86 <= 7.0.17 7.0.18

.NET 8.0

Package name Affected version Patched version
Microsoft.WindowsDesktop.App.Runtime.win-arm64 <= 8.0.3 8.0.4
Microsoft.WindowsDesktop.App.Runtime.win-x64 <= 8.0.3 8.0.4
Microsoft.WindowsDesktop.App.Runtime.win-x86 <= 8.0.3 8.0.4

Advisory FAQ

How do I know if I am affected?

If you have a runtime or SDK with a version listed, or an affected package listed in affected software or affected packages, you're exposed to the vulnerability.

How do I fix the issue?

.NET Core SDK (reflecting any global.json):


 Version:   8.0.204
 Commit:    8473146e7d

Runtime Environment:

 OS Name:     Windows
 OS Version:  10.0.18363
 OS Platform: Windows
 RID:         win10-x64
 Base Path:   C:\Program Files\dotnet\sdk\6.0.300\

Host (useful for support):

  Version: 8.0.4
  Commit:  8473146e7d

.NET Core SDKs installed:

  8.0.204 [C:\Program Files\dotnet\sdk]

.NET Core runtimes installed:

  Microsoft.AspWindowsDesktop.App 8.0.4 [C:\Program Files\dotnet\shared\Microsoft.AspWindowsDesktop.App]
  Microsoft.WindowsDesktop.App 8.0.4 [C:\Program Files\dotnet\shared\Microsoft.WindowsDesktop.App]
  Microsoft.WindowsDesktop.App 8.0.4 [C:\Program Files\dotnet\shared\Microsoft.WindowsDesktop.App]


To install additional .NET Core runtimes or SDKs:
  https://aka.ms/dotnet-download

.NET 6.0, .NET 7.0 and, .NET 8.0 updates are also available from Microsoft Update. To access this either type "Check for updates" in your Windows search, or open Settings, choose Update & Security and then click Check for Updates.

Once you have installed the updated runtime or SDK, restart your apps for the update to take effect.

Additionally, if you've deployed self-contained applications targeting any of the impacted versions, these applications are also vulnerable and must be recompiled and redeployed.

Other Information

Reporting Security Issues

If you have found a potential security issue in .NET 8.0 or .NET 7.0 or .NET 6.0, please email details to [email protected]. Reports may qualify for the Microsoft .NET Core & .NET 5 Bounty. Details of the Microsoft .NET Bounty Program including terms and conditions are at https://aka.ms/corebounty.

Support

You can ask questions about this issue on GitHub in the .NET GitHub organization. The main repos are located at https://github.com/dotnet/runtime and https://github.com/dotnet/aspnet/. The Announcements repo (https://github.com/dotnet/Announcements) will contain this bulletin as an issue and will include a link to a discussion issue. You can ask questions in the linked discussion issue.

Disclaimer

The information provided in this advisory is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

External Links

CVE-2024-21409

Revisions

V1.0 (April 09, 2024): Advisory published.

Version 1.0

Last Updated 2024-04-09

Permalink: https://github.com/advisories/GHSA-6qmx-42h2-j8h6
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS02cW14LTQyaDItajhoNs4AA7I9
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 1 month ago
Updated: about 1 month ago


CVSS Score: 7.3
CVSS vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Identifiers: GHSA-6qmx-42h2-j8h6, CVE-2024-21409
References: Repository: https://github.com/dotnet/wpf
Blast Radius: 1.0

Affected Packages

nuget:Microsoft.WindowsDesktop.App.Runtime.win-x86
Dependent packages: 0
Dependent repositories: 0
Downloads: 9,763,200 total
Affected Version Ranges: <= 6.0.28, >= 8.0.0, <= 8.0.3, >= 7.0.0, <= 7.0.17
Fixed in: 6.0.29, 8.0.4, 7.0.18
All affected versions: 3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.1.0, 3.1.1, 3.1.2, 3.1.3, 3.1.4, 3.1.5, 3.1.6, 3.1.7, 3.1.8, 3.1.9, 3.1.10, 3.1.11, 3.1.12, 3.1.13, 3.1.14, 3.1.15, 3.1.16, 3.1.17, 3.1.18, 3.1.19, 3.1.20, 3.1.21, 3.1.22, 3.1.23, 3.1.24, 3.1.25, 3.1.26, 3.1.27, 3.1.28, 3.1.29, 3.1.30, 3.1.31, 3.1.32, 5.0.0, 5.0.1, 5.0.2, 5.0.3, 5.0.4, 5.0.5, 5.0.6, 5.0.7, 5.0.8, 5.0.9, 5.0.10, 5.0.11, 5.0.12, 5.0.13, 5.0.14, 5.0.15, 5.0.16, 5.0.17, 6.0.0, 6.0.1, 6.0.2, 6.0.3, 6.0.4, 6.0.5, 6.0.6, 6.0.7, 6.0.8, 6.0.9, 6.0.10, 6.0.11, 6.0.12, 6.0.13, 6.0.14, 6.0.15, 6.0.16, 6.0.18, 6.0.19, 6.0.20, 6.0.21, 6.0.22, 6.0.23, 6.0.24, 6.0.25, 6.0.26, 6.0.27, 6.0.28, 7.0.0, 7.0.1, 7.0.2, 7.0.3, 7.0.4, 7.0.5, 7.0.7, 7.0.8, 7.0.9, 7.0.10, 7.0.11, 7.0.12, 7.0.13, 7.0.14, 7.0.15, 7.0.16, 7.0.17, 8.0.0, 8.0.1, 8.0.2, 8.0.3
All unaffected versions: 6.0.29, 7.0.18, 7.0.19, 8.0.4, 8.0.5
nuget:Microsoft.WindowsDesktop.App.Runtime.win-x64
Dependent packages: 0
Dependent repositories: 0
Downloads: 43,969,290 total
Affected Version Ranges: >= 7.0.0, <= 7.0.17, >= 8.0.0, <= 8.0.3, <= 6.0.28
Fixed in: 7.0.18, 8.0.4, 6.0.29
All affected versions: 3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.1.0, 3.1.1, 3.1.2, 3.1.3, 3.1.4, 3.1.5, 3.1.6, 3.1.7, 3.1.8, 3.1.9, 3.1.10, 3.1.11, 3.1.12, 3.1.13, 3.1.14, 3.1.15, 3.1.16, 3.1.17, 3.1.18, 3.1.19, 3.1.20, 3.1.21, 3.1.22, 3.1.23, 3.1.24, 3.1.25, 3.1.26, 3.1.27, 3.1.28, 3.1.29, 3.1.30, 3.1.31, 3.1.32, 5.0.0, 5.0.1, 5.0.2, 5.0.3, 5.0.4, 5.0.5, 5.0.6, 5.0.7, 5.0.8, 5.0.9, 5.0.10, 5.0.11, 5.0.12, 5.0.13, 5.0.14, 5.0.15, 5.0.16, 5.0.17, 6.0.0, 6.0.1, 6.0.2, 6.0.3, 6.0.4, 6.0.5, 6.0.6, 6.0.7, 6.0.8, 6.0.9, 6.0.10, 6.0.11, 6.0.12, 6.0.13, 6.0.14, 6.0.15, 6.0.16, 6.0.18, 6.0.19, 6.0.20, 6.0.21, 6.0.22, 6.0.23, 6.0.24, 6.0.25, 6.0.26, 6.0.27, 6.0.28, 7.0.0, 7.0.1, 7.0.2, 7.0.3, 7.0.4, 7.0.5, 7.0.7, 7.0.8, 7.0.9, 7.0.10, 7.0.11, 7.0.12, 7.0.13, 7.0.14, 7.0.15, 7.0.16, 7.0.17, 8.0.0, 8.0.1, 8.0.2, 8.0.3
All unaffected versions: 6.0.29, 6.0.30, 7.0.18, 7.0.19, 8.0.4, 8.0.5
nuget:Microsoft.WindowsDesktop.App.Runtime.win-arm64
Dependent packages: 0
Dependent repositories: 0
Downloads: 2,146,160 total
Affected Version Ranges: >= 7.0.0, <= 7.0.17, >= 8.0.0, <= 8.0.3, <= 6.0.28
Fixed in: 7.0.18, 8.0.4, 6.0.29
All affected versions: 5.0.0, 5.0.1, 5.0.2, 5.0.3, 5.0.4, 5.0.5, 5.0.6, 5.0.7, 5.0.8, 5.0.9, 5.0.10, 5.0.11, 5.0.12, 5.0.13, 5.0.14, 5.0.15, 5.0.16, 5.0.17, 6.0.0, 6.0.1, 6.0.2, 6.0.3, 6.0.4, 6.0.5, 6.0.6, 6.0.7, 6.0.8, 6.0.9, 6.0.10, 6.0.11, 6.0.12, 6.0.13, 6.0.14, 6.0.15, 6.0.16, 6.0.18, 6.0.19, 6.0.20, 6.0.21, 6.0.22, 6.0.23, 6.0.24, 6.0.25, 6.0.26, 6.0.27, 6.0.28, 7.0.0, 7.0.1, 7.0.2, 7.0.3, 7.0.4, 7.0.5, 7.0.7, 7.0.8, 7.0.9, 7.0.10, 7.0.11, 7.0.12, 7.0.13, 7.0.14, 7.0.15, 7.0.16, 7.0.17, 8.0.0, 8.0.1, 8.0.2, 8.0.3
All unaffected versions: 6.0.29, 6.0.30, 7.0.18, 7.0.19, 8.0.4, 8.0.5