Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS03MjNwLTlyY2oteHY4as4AAjkq

RCE vulnerability in RadarGun Plugin

RadarGun Plugin 1.7 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types. This results in a remote code execution vulnerability exploitable by users able to configure RadarGun Plugin’s build step.

RadarGun Plugin 1.8 configures its YAML parser to only instantiate safe types.

Permalink: https://github.com/advisories/GHSA-723p-9rcj-xv8j
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS03MjNwLTlyY2oteHY4as4AAjkq
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 2 years ago
Updated: 7 months ago


CVSS Score: 8.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-723p-9rcj-xv8j, CVE-2020-2123
References: Repository: https://github.com/jenkinsci/radargun-plugin
Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:radargun
Affected Version Ranges: < 1.8
Fixed in: 1.8