Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS03NHczLXA4OXgtZmZnaM4AAu19

ansi_term is Unmaintained

Withdrawn Advisory

This advisory has been withdrawn because it does not discuss a particular vulnerability in the code of ansi_term.

Original Description

The maintainer has adviced this crate is deprecated and will not receive any maintenance.

The crate does not seem to have much dependencies and may or may not be ok to use as-is.

Last release seems to have been three years ago.

Permalink: https://github.com/advisories/GHSA-74w3-p89x-ffgh
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS03NHczLXA4OXgtZmZnaM4AAu19
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Low
Classification: General
Published: almost 2 years ago
Updated: over 1 year ago

Widthdrawn: almost 2 years ago

Identifiers: GHSA-74w3-p89x-ffgh
References: Repository: https://github.com/ogham/rust-ansi-term
Blast Radius: 0.0

Affected Packages

cargo:ansi_term
Dependent packages: 878
Dependent repositories: 37,809
Downloads: 114,845,692 total
Affected Version Ranges: >= 0
No known fixed version
All affected versions: 0.2.0, 0.3.0, 0.4.0, 0.4.1, 0.4.2, 0.4.3, 0.4.4, 0.4.5, 0.4.6, 0.5.0, 0.5.1, 0.5.2, 0.6.0, 0.6.1, 0.6.2, 0.6.3, 0.7.0, 0.7.1, 0.7.2, 0.7.4, 0.7.5, 0.8.0, 0.9.0, 0.10.1, 0.10.2, 0.11.0, 0.12.0, 0.12.1