Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS03OTRqLWh4OTYtNHczbc0zCg

CSRF vulnerability and missing permission checks in Jenkins kubernetes-cd Plugin allow capturing credentials

A missing permission check in Jenkins Kubernetes Continuous Deploy Plugin 2.3.1 and earlier allows attackers with Overall/Read permission to connect to an attacker-specified SSH server using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

Permalink: https://github.com/advisories/GHSA-794j-hx96-4w3m
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS03OTRqLWh4OTYtNHczbc0zCg
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 2 years ago
Updated: 9 months ago


CVSS Score: 7.1
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N

Identifiers: GHSA-794j-hx96-4w3m, CVE-2022-27211
References: Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:kubernetes-cd
Affected Version Ranges: <= 2.3.1
No known fixed version