Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS03OTV3LTc0MjYtbTk0as4AAyCB

stoqey/gnuplot is vulnerable to command injection

An issue found in Stoqey gnuplot v.0.0.3 and earlier allows attackers to execute arbitrary code via the src/index.ts, plotCallack, child_process, and/or filePath parameter(s).

Permalink: https://github.com/advisories/GHSA-795w-7426-m94j
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS03OTV3LTc0MjYtbTk0as4AAyCB
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: about 1 year ago
Updated: about 1 year ago


CVSS Score: 9.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-795w-7426-m94j, CVE-2021-33360
References: Repository: https://github.com/stoqey/gnuplot
Blast Radius: 0.0

Affected Packages

npm:@stoqey/gnuplot
Dependent packages: 2
Dependent repositories: 1
Downloads: 21 last month
Affected Version Ranges: <= 0.0.3
No known fixed version
All affected versions: 0.0.1, 0.0.2, 0.0.3