Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS03amg4LWdod2MtODJjd802ng

Cross-site Scripting (XSS) vulnerability in Jenkins Continuous Integration with Toad Edge Plugin

Jenkins Continuous Integration with Toad Edge Plugin 2.3 and earlier does not apply Content-Security-Policy headers to report files it serves, resulting in a stored cross-site scripting (XSS) exploitable by attackers with Item/Configure permission or otherwise able to control report contents.

Permalink: https://github.com/advisories/GHSA-7jh8-ghwc-82cw
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS03amg4LWdod2MtODJjd802ng
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 2 years ago
Updated: 7 months ago


CVSS Score: 8.0
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Identifiers: GHSA-7jh8-ghwc-82cw, CVE-2022-28145
References: Repository: https://github.com/jenkinsci/ci-with-toad-edge-plugin
Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:ci-with-toad-edge
Affected Version Ranges: < 2.4
Fixed in: 2.4