Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS03bXA2LTkyOXAtcHFoas4AA19V

Croc requires senders to provide local IP addresses in cleartext

An issue was discovered in Croc before 9.6.16. The protocol requires a sender to provide its local IP addresses in cleartext via an ips? message.

Permalink: https://github.com/advisories/GHSA-7mp6-929p-pqhj
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS03bXA2LTkyOXAtcHFoas4AA19V
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: 10 months ago
Updated: 2 months ago


CVSS Score: 5.3
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Identifiers: GHSA-7mp6-929p-pqhj, CVE-2023-43618
References: Repository: https://github.com/schollz/croc
Blast Radius: 2.5

Affected Packages

go:github.com/schollz/croc/v9
Dependent packages: 5
Dependent repositories: 3
Downloads:
Affected Version Ranges: < 9.6.16
Fixed in: 9.6.16
All affected versions: 9.0.0, 9.1.0, 9.1.1, 9.1.2, 9.1.3, 9.1.4, 9.1.5, 9.1.6, 9.2.0, 9.2.1, 9.3.0, 9.4.0, 9.4.1, 9.4.2, 9.5.0, 9.5.1, 9.5.2, 9.5.3, 9.5.4, 9.5.5, 9.5.6, 9.6.0, 9.6.1, 9.6.2, 9.6.3, 9.6.4, 9.6.5, 9.6.6, 9.6.7, 9.6.8, 9.6.9, 9.6.10, 9.6.11, 9.6.12, 9.6.13, 9.6.14, 9.6.15
All unaffected versions: 9.6.16, 9.6.17