Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS03cTlyLXZoZzItNzg5d84AAjkS

Stored XSS vulnerability in Jenkins brakeman Plugin

brakeman Plugin 0.12 and earlier did not escape values received from parsed JSON files when rendering them, resulting in a stored cross-site scripting vulnerability.

This vulnerability can be exploited by users able to control the Brakeman post-build step input data.\n\nbrakeman Plugin 0.13 escape affected values from the parsed file as they are recorded.

This fix is only applied to newly recorded data after a fixed version of the plugin is installed; historical data may still contain unsafe values.

Permalink: https://github.com/advisories/GHSA-7q9r-vhg2-789w
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS03cTlyLXZoZzItNzg5d84AAjkS
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: over 1 year ago


CVSS Score: 5.4
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-7q9r-vhg2-789w, CVE-2020-2122
References: Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:brakeman
Affected Version Ranges: < 0.13
Fixed in: 0.13