Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS03cXBtLXZtd3YtaHE3aM4AAu-m

Stored XSS vulnerability in Jenkins Walti plugin

Jenkins Walti Plugin 1.0.1 and earlier does not escape the information provided by the Walti API, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide malicious API responses from Walti.

Permalink: https://github.com/advisories/GHSA-7qpm-vmwv-hq7h
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS03cXBtLXZtd3YtaHE3aM4AAu-m
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: almost 2 years ago
Updated: over 1 year ago


CVSS Score: 7.5
CVSS vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Identifiers: GHSA-7qpm-vmwv-hq7h, CVE-2022-41240
References: Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:walti
Affected Version Ranges: <= 1.0.1
No known fixed version