Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS03eDc2LTU3ZnItbTVyNc4AA6JN

GeoServer's MapML HTML Page vulnerable to Stored Cross-Site Scripting (XSS)

Summary

A stored cross-site scripting (XSS) vulnerability exists that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in the GeoServer catalog that will execute in the context of another user's browser when viewed in the MapML HTML Page. The MapML extension must be installed and access to the MapML HTML Page is available to all users although data security may limit users' ability to trigger the XSS.

Impact

If an attacker can control a script that is executed in the victim's browser, then they can typically fully compromise that user. Amongst other things, the attacker can:

1 .Perform any action within the application that the user can perform.
2. View any information that the user is able to view.
3. Modify any information that the user is able to modify.
4. Initiate interactions with other application users, including malicious attacks, that will appear to originate from the initial victim user.

References

https://osgeo-org.atlassian.net/browse/GEOS-11154
https://github.com/geoserver/geoserver/pull/7175

Permalink: https://github.com/advisories/GHSA-7x76-57fr-m5r5
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS03eDc2LTU3ZnItbTVyNc4AA6JN
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: 2 months ago
Updated: 2 months ago


CVSS Score: 4.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-7x76-57fr-m5r5, CVE-2024-23819
References: Repository: https://github.com/geoserver/geoserver
Blast Radius: 1.0

Affected Packages

maven:org.geoserver.extension:gs-mapml
Affected Version Ranges: >= 2.24.0, < 2.24.1, < 2.23.4
Fixed in: 2.24.1, 2.23.4