Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS04MjM3LTNxNWctOTlmds4AAxzz

Denial of Service vulnerability in lite-web-server

All versions of the package lite-web-server are vulnerable to Denial of Service (DoS) when an attacker sends an HTTP request and includes control characters that the decodeURI() function is unable to parse.

Permalink: https://github.com/advisories/GHSA-8237-3q5g-99fv
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS04MjM3LTNxNWctOTlmds4AAxzz
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 1 year ago
Updated: over 1 year ago


CVSS Score: 7.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Identifiers: GHSA-8237-3q5g-99fv, CVE-2023-26104
References: Repository: https://github.com/chasyumen/lite-web-server
Blast Radius: 1.0

Affected Packages

npm:lite-web-server
Dependent packages: 1
Dependent repositories: 0
Downloads: 34 last month
Affected Version Ranges: <= 1.2.2
No known fixed version
All affected versions: 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8, 1.0.9, 1.0.10, 1.1.0, 1.1.1, 1.2.0, 1.2.1, 1.2.2