Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS04MzNtLTM3ZjctanE1Nc4AA5Kr

Rancher API Server Cross-site Scripting Vulnerability

Impact

A vulnerability has been identified in which unauthenticated cross-site scripting (XSS) in the API Server's public API endpoint can be exploited. This can lead to an attacker exploiting the vulnerability to trigger JavaScript code and execute commands remotely.

The attack vector was identified as a Reflected XSS.

API Server propagates malicious payloads from user input to the UI, which renders the output. For example, a malicious URL gets rendered into a script that is executed on a page.

The changes addressed by this fix are:

Patches

Patched versions include the following commits:

Branch Commit
master 4fd7d82
release/v2.8 69b3c2b
release/v2.8.s3 a3b9e37
release/v2.7 4e102cf
release/v2.7.s3 97a10a3
release/v2.6 4df268e

Workarounds

There is no direct mitigation besides updating API Server to a patched version.

References

If you have any questions or comments about this advisory:

Permalink: https://github.com/advisories/GHSA-833m-37f7-jq55
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS04MzNtLTM3ZjctanE1Nc4AA5Kr
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: 22 days ago
Updated: 22 days ago


CVSS Score: 8.3
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L

Identifiers: GHSA-833m-37f7-jq55, CVE-2023-32192
References:

Affected Packages

go:github.com/rancher/apiserver
Versions: < 0.0.0-20240207153957-4fd7d821d952
Fixed in: 0.0.0-20240207153957-4fd7d821d952