Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS04NDZnLXA3aG0tZjU0cs4AA7Ba

AWS Amplify CLI has incorrect trust policy management

Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM roles associated with Amplify projects. When the Authentication component is removed from an Amplify project, a Condition property is removed but "Effect":"Allow" remains present, and consequently sts:AssumeRoleWithWebIdentity would be available to threat actors with no conditions. Thus, if Amplify CLI had been used to remove the Authentication component from a project built between August 2019 and January 2024, an "assume role" may have occurred, and may have been leveraged to obtain unauthorized access to an organization's AWS resources. NOTE: the problem could only occur if an authorized AWS user removed an Authentication component. (The vulnerability did not give a threat actor the ability to remove an Authentication component.) However, in realistic situations, an authorized AWS user may have removed an Authentication component, e.g., if the objective were to stop using built-in Cognito resources, or move to a completely different identity provider.

Permalink: https://github.com/advisories/GHSA-846g-p7hm-f54r
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS04NDZnLXA3aG0tZjU0cs4AA7Ba
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 1 month ago
Updated: about 1 month ago


Identifiers: GHSA-846g-p7hm-f54r, CVE-2024-28056
References: Repository: https://github.com/aws-amplify/amplify-cli
Blast Radius: 0.0

Affected Packages

npm:@aws-amplify/cli
Dependent packages: 18
Dependent repositories: 268
Downloads: 1,345,791 last month
Affected Version Ranges: < 12.10.1
Fixed in: 12.10.1
All affected versions: 0.1.13, 0.1.14, 0.1.15, 0.1.16, 0.1.17, 0.1.18, 0.1.19, 0.1.20, 0.1.21, 0.1.22, 0.1.23, 0.1.24, 0.1.26, 0.1.27, 0.1.28, 0.1.29, 0.1.30, 0.1.31, 0.1.32, 0.1.33, 0.1.34, 0.1.35, 0.1.36, 0.1.37, 0.1.38, 0.1.40, 0.1.41, 0.1.42, 0.1.43, 0.1.44, 0.1.45, 0.2.1, 1.0.5, 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.1.6, 1.1.7, 1.1.8, 1.4.0, 1.5.0, 1.5.1, 1.5.3, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.6.6, 1.6.7, 1.6.8, 1.6.9, 1.6.10, 1.6.11, 1.7.0, 1.7.1, 1.7.2, 1.7.3, 1.7.4, 1.7.5, 1.7.6, 1.7.8, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.9.0, 1.10.0, 1.11.0, 1.12.0, 2.0.0, 3.0.0, 3.1.0, 3.2.0, 3.3.0, 3.4.0, 3.5.0, 3.7.0, 3.8.0, 3.9.0, 3.10.0, 3.11.0, 3.12.0, 3.13.0, 3.14.0, 3.15.0, 3.16.0, 3.17.0, 4.0.0, 4.1.0, 4.1.1, 4.2.0, 4.4.0, 4.5.0, 4.6.0, 4.7.0, 4.8.0, 4.9.0, 4.10.0, 4.11.0, 4.12.0, 4.13.0, 4.13.1, 4.13.2, 4.13.3, 4.13.4, 4.14.1, 4.16.0, 4.16.1, 4.17.0, 4.17.1, 4.17.2, 4.18.0, 4.18.1, 4.19.0, 4.20.0, 4.21.0, 4.21.1, 4.21.2, 4.21.3, 4.21.4, 4.22.0, 4.23.0, 4.23.1, 4.24.0, 4.24.1, 4.24.2, 4.24.3, 4.25.0, 4.26.0, 4.27.0, 4.27.1, 4.27.2, 4.27.3, 4.28.0, 4.28.1, 4.28.2, 4.29.0, 4.29.1, 4.29.2, 4.29.3, 4.29.4, 4.29.5, 4.29.6, 4.29.7, 4.29.8, 4.30.0, 4.31.0, 4.31.1, 4.32.0, 4.32.1, 4.34.0, 4.35.0, 4.36.0, 4.36.1, 4.36.2, 4.37.0, 4.37.1, 4.38.0, 4.38.1, 4.38.2, 4.39.0, 4.40.0, 4.40.1, 4.41.0, 4.41.1, 4.41.2, 4.42.0, 4.43.0, 4.44.0, 4.44.1, 4.44.2, 4.45.0, 4.45.1, 4.45.2, 4.46.0, 4.46.1, 4.47.1, 4.48.0, 4.49.0, 4.50.0, 4.50.2, 4.51.0, 4.51.1, 4.51.2, 4.51.3, 4.51.4, 4.52.0, 5.0.0, 5.0.1, 5.0.2, 5.1.0, 5.1.1, 5.1.2, 5.2.0, 5.2.1, 5.3.0, 5.3.1, 5.4.0, 5.5.0, 5.6.0, 6.0.0, 6.0.1, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.3.0, 6.3.1, 6.4.0, 7.3.0, 7.3.1, 7.3.2, 7.3.3, 7.3.4, 7.3.5, 7.3.6, 7.4.0, 7.4.1, 7.4.2, 7.4.3, 7.4.4, 7.4.5, 7.5.0, 7.5.1, 7.5.2, 7.5.3, 7.5.4, 7.5.5, 7.5.6, 7.6.0, 7.6.1, 7.6.2, 7.6.3, 7.6.4, 7.6.5, 7.6.7, 7.6.8, 7.6.9, 7.6.10, 7.6.11, 7.6.12, 7.6.13, 7.6.14, 7.6.15, 7.6.19, 7.6.20, 7.6.21, 7.6.22, 7.6.23, 7.6.24, 7.6.25, 7.6.26, 8.0.0, 8.0.1, 8.0.2, 8.0.3, 8.1.0, 8.2.0, 8.3.0, 8.3.1, 8.4.0, 8.5.0, 8.5.1, 9.0.0, 9.1.0, 9.2.0, 9.2.1, 10.0.0, 10.1.0, 10.2.0, 10.2.1, 10.2.2, 10.2.3, 10.3.0, 10.3.1, 10.3.2, 10.4.0, 10.4.1, 10.5.0, 10.5.1, 10.5.2, 10.6.0, 10.6.1, 10.6.2, 10.7.0, 10.7.1, 10.7.2, 10.7.3, 10.8.0, 10.8.1, 11.0.0, 11.0.1, 11.0.2, 11.0.3, 11.0.4, 11.0.5, 11.1.0, 11.1.1, 12.0.0, 12.0.1, 12.0.2, 12.0.3, 12.1.0, 12.1.1, 12.2.0, 12.2.1, 12.2.2, 12.2.3, 12.2.4, 12.2.5, 12.3.0, 12.4.0, 12.5.0, 12.5.1, 12.5.2, 12.6.0, 12.7.0, 12.7.1, 12.8.2, 12.9.0, 12.10.0
All unaffected versions: 12.10.1, 12.10.2, 12.10.3, 12.11.0, 12.11.1, 12.12.0