Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS04NzlwLThndzQtbWNwd84AA6CK

fgr Vulnerable to Insecure Default Variable Initialization

Impact

Any users whom would not desire a traceback to be included in their logs whenever an error is raised in their code will be affected.

If users have inadvertently created a scenario in their code that could cause a traceback to include sensitive information and a malicious entity gained access to their log stream, this could create an issue.

Patches

None yet... users will need to upgrade to 0.4.*

Workarounds

No particularly reasonable ones at present.

References

Permalink: https://github.com/advisories/GHSA-879p-8gw4-mcpw
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS04NzlwLThndzQtbWNwd84AA6CK
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Low
Classification: General
Published: about 1 month ago
Updated: about 1 month ago


CVSS Score: 3.7
CVSS vector: CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-879p-8gw4-mcpw
References: Repository: https://github.com/dan1hc/fgr
Blast Radius: 1.0

Affected Packages

pypi:fgr
Dependent packages: 0
Dependent repositories: 0
Downloads: 1,208 last month
Affected Version Ranges: <= 0.3.2
No known fixed version
All affected versions: 0.1.4, 0.1.5, 0.1.6, 0.1.7, 0.2.0, 0.2.1, 0.3.0, 0.3.1, 0.3.2