Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS04OGo0LXBjeDgtcTRxM84AA3q_

Password Change Vulnerability

Overview:

A moderate security vulnerability has been identified in Uptime Kuma platform that poses a significant threat to the confidentiality and integrity of user accounts.
When a user changes their login password in Uptime Kuma, a previously logged-in user retains access without being logged out.
This behaviour persists consistently, even after system restarts or browser restarts.
This vulnerability allows unauthorized access to user accounts, compromising the security of sensitive information.

The same vulnerability was partially fixed in https://github.com/louislam/uptime-kuma/security/advisories/GHSA-g9v2-wqcj-j99g but logging existing users out of their accounts was forgotten.

Impact:

The impact of this vulnerability is moderate, as it enables attackers or unauthorized individuals to maintain access to user accounts even after the account password has been changed. This can lead to unauthorized data access, manipulation, or compromise of user accounts, posing a threat to the integrity and confidentiality of Uptime Kuma.
A better impact-analysis is included in https://github.com/louislam/uptime-kuma/security/advisories/GHSA-g9v2-wqcj-j99g

PoC

Remediation:

To mitigate the risks associated with this vulnerability, we made the server emit a refresh event (clients handle this by reloading) and then disconnecting all clients except the one initiating the password change.

It is recommended to Update Uptime Kuma to >= 1.23.9.

Timeline:

Date Event
2023-12-07 14:35 UTC @manoonabbasi discovered and posts this information as a bug-report in issue #4188 [^1] into our public issue tracker, which is against our security policy
2023-12-07 16:50 UTC The Uptime Kuma team deleted the post in our issue tracker
2023-12-10 18:10 UTC Uptime Kuma team released patch and this Advisory

[^1]: deleted to prevent the spread of this vulnerability without there being a fix available

Permalink: https://github.com/advisories/GHSA-88j4-pcx8-q4q3
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS04OGo0LXBjeDgtcTRxM84AA3q_
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: 7 months ago
Updated: 7 months ago


CVSS Score: 6.7
CVSS vector: CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-88j4-pcx8-q4q3, CVE-2023-49804
References: Repository: https://github.com/louislam/uptime-kuma
Blast Radius: 1.0

Affected Packages

npm:uptime-kuma
Dependent packages: 0
Dependent repositories: 0
Downloads: 99 last month
Affected Version Ranges: < 1.23.9
Fixed in: 1.23.9
All affected versions:
All unaffected versions: