Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS04OHdjLWZjajktcTNyOc4AA6JO

GeoServer's GWC Demos Page vulnerable to Stored Cross-Site Scripting (XSS)

Summary

A stored cross-site scripting (XSS) vulnerability exists that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in the GeoServer catalog that will execute in the context of another user's browser when viewed in the GWC Demos Page. Access to the GWC Demos Page is available to all users although data security may limit users' ability to trigger the XSS.

Impact

If an attacker can control a script that is executed in the victim's browser, then they can typically fully compromise that user. Amongst other things, the attacker can:

1 .Perform any action within the application that the user can perform.
2. View any information that the user is able to view.
3. Modify any information that the user is able to modify.
4. Initiate interactions with other application users, including malicious attacks, that will appear to originate from the initial victim user.

References

https://github.com/GeoWebCache/geowebcache/issues/1171
https://github.com/GeoWebCache/geowebcache/pull/1173

Permalink: https://github.com/advisories/GHSA-88wc-fcj9-q3r9
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS04OHdjLWZjajktcTNyOc4AA6JO
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: 29 days ago
Updated: 28 days ago


CVSS Score: 4.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-88wc-fcj9-q3r9, CVE-2024-23821
References: Repository: https://github.com/geoserver/geoserver
Blast Radius: 1.0

Affected Packages

maven:org.geoserver:gs-gwc
Affected Version Ranges: < 2.23.4, >= 2.24.0, < 2.24.1
Fixed in: 2.23.4, 2.24.1