Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS04Z3djLXg3bWctN3A3cM4AATJg

Apache XML Security For Java vulnerable to Infinite Loop

Affected versions of xmlsec are subject to a denial of service vulnerability. Should a user check the signature of a message larger than 512 MB, the method expandSize(int newPos) of class org.apache.xml.security.utils.UnsyncByteArrayOutputStream goes in an endless loop. A remote attacker could use this flaw to supply crafted XML that would lead to a denial of service.

Permalink: https://github.com/advisories/GHSA-8gwc-x7mg-7p7p
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS04Z3djLXg3bWctN3A3cM4AATJg
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: 3 months ago


Identifiers: GHSA-8gwc-x7mg-7p7p, CVE-2013-5823
References: Repository: https://github.com/apache/santuario-java
Blast Radius: 0.0

Affected Packages

maven:org.apache.santuario:xmlsec
Dependent packages: 352
Dependent repositories: 2,584
Downloads:
Affected Version Ranges: >= 1.5.0, < 1.5.3, >= 1.4.0, < 1.4.8
Fixed in: 1.5.3, 1.4.8
All affected versions: 1.4.3, 1.4.4, 1.4.5, 1.4.6, 1.4.7, 1.5.0, 1.5.1, 1.5.2
All unaffected versions: 1.4.8, 1.5.3, 1.5.4, 1.5.5, 1.5.6, 1.5.7, 1.5.8, 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.0.8, 2.0.9, 2.0.10, 2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.1.5, 2.1.6, 2.1.7, 2.1.8, 2.2.0, 2.2.1, 2.2.2, 2.2.3, 2.2.4, 2.2.5, 2.2.6, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 4.0.0, 4.0.1, 4.0.2