Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS04ZjI1LXc3cWotcjdoY84AA6i3

Temporal UI Server cross-site scripting vulnerability

For an attacker with pre-existing access to send a signal to a workflow, the attacker can make the signal name a script that executes when a victim views that signal. The XSS is in the timeline page displaying the workflow execution details of the workflow that was sent the crafted signal.
Access to send a signal to a workflow is determined by how you configured the authorizer on your server. This includes any entity with permission to directly call SignalWorkflowExecution or SignalWithStartWorkflowExecution, or any entity can deploy a worker that has access to call workflow progress APIs (specifically RespondWorkflowTaskCompleted).

Permalink: https://github.com/advisories/GHSA-8f25-w7qj-r7hc
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS04ZjI1LXc3cWotcjdoY84AA6i3
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 months ago
Updated: about 2 months ago


CVSS Score: 4.3
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L

Identifiers: GHSA-8f25-w7qj-r7hc, CVE-2024-2435
References: Repository: https://github.com/temporalio/ui-server
Blast Radius: 1.3

Affected Packages

go:github.com/temporalio/ui-server/v2
Dependent packages: 12
Dependent repositories: 2
Downloads:
Affected Version Ranges: < 2.25.0
Fixed in: 2.25.0
All affected versions: 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.2.0, 2.2.1, 2.2.2, 2.2.3, 2.3.0, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.8.2, 2.8.3, 2.9.0, 2.9.1, 2.10.0, 2.10.1, 2.10.2, 2.10.3, 2.11.0, 2.11.1, 2.11.2, 2.12.0, 2.13.0, 2.13.1, 2.13.2, 2.13.3, 2.14.0, 2.15.0, 2.16.0, 2.16.1, 2.16.2, 2.17.0, 2.17.1, 2.17.2, 2.18.0, 2.18.1, 2.18.2, 2.19.0, 2.20.0, 2.21.0, 2.21.1, 2.21.2, 2.21.3, 2.21.4, 2.22.0, 2.22.1, 2.22.2, 2.22.3, 2.23.0, 2.24.0
All unaffected versions: 2.25.0, 2.26.0, 2.26.1, 2.26.2, 2.27.0, 2.27.1