Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS04ZjZtLWdmcTktZzMzds4AAb62

Cross-site Scripting in html5lib

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of special characters in attribute values, a different vulnerability than CVE-2016-9909.

Permalink: https://github.com/advisories/GHSA-8f6m-gfq9-g33v
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS04ZjZtLWdmcTktZzMzds4AAb62
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: over 1 year ago


CVSS Score: 6.1
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-8f6m-gfq9-g33v, CVE-2016-9910
References: Repository: https://github.com/html5lib/html5lib-python
Blast Radius: 28.5

Affected Packages

pypi:html5lib
Dependent packages: 419
Dependent repositories: 46,793
Downloads: 17,365,003 last month
Affected Version Ranges: < 0.99999999
Fixed in: 0.99999999
All affected versions: 0.11.1
All unaffected versions: 1.0.1